Degraded Performance

Incident Report for Irth Solutions - UtiliSphere (CL)

Resolved

Performance has returned to normal and we are no longer observing signs of degradation. We will continue to monitor closely and provide further updates as needed.
Posted Jun 29, 2026 - 13:51 EDT

Update

Our mitigation steps remain in place and we are closely monitoring system performance. Investigation into the underlying cause is ongoing. We will provide another update within the hour.
Posted Jun 29, 2026 - 13:23 EDT

Monitoring

We have taken mitigation steps that appear to have improved performance for most users. We are continuing to investigate the underlying cause. We will provide another update within the hour.
Posted Jun 29, 2026 - 12:24 EDT

Update

We continue to investigate this issue. We have applied configuration changes that may improve performance for some users while we work toward a full resolution. We will provide another update within the hour.
Posted Jun 29, 2026 - 11:51 EDT

Investigating

We are investigating reports of intermittent slowness affecting some customers. Our team is actively working to identify the root cause. We will provide an update within the hour.

We apologize for any inconvenience.
Posted Jun 29, 2026 - 11:11 EDT
This incident affected: UtiliSphere.